On 6/8/07, Sven Neumann <[EMAIL PROTECTED]> wrote:
> Hi,
>
> On Thu, 2007-06-07 at 19:31 +0930, David Gowers wrote:
>
> > > As far as I can see, updated versions of the generated files have been
> > > committed to SVN. What exactly is your problem?
> > >
> > Don't know. I just did the standard './autogen.sh;make' after running
> > 'svn update' and make eventually crashed with the mentioned messages.
>
> Well, you didn't mention the message yet. That's why I asked you to
> describe the problem in more detail.
>
>
> Sven

Something has gone badly wrong. I did quote them.. I may have even
quoted them twice.
I don't have a copy of the errors saved, but this is what happened roughly:

1. 'make' runs. Eventually it reaches the imagemap plugin directory.
2. imap_csim.l is used to generate imap_csim_(parse|lex).[ch] with flex.
3. Either imap_csim_parse.c or imap_csim_lex.c is complained about by
the compiler:

<stdout>:1839: warning: no previous prototype for 'csim_get_lineno'
<stdout>:1848: warning: no previous prototype for 'csim_get_in'
<stdout>:1856: warning: no previous prototype for 'csim_get_out'
<stdout>:1864: warning: no previous prototype for 'csim_get_leng'
<stdout>:1873: warning: no previous prototype for 'csim_get_text'
<stdout>:1882: warning: no previous prototype for 'csim_set_lineno'
<stdout>:1894: warning: no previous prototype for 'csim_set_in'
<stdout>:1899: warning: no previous prototype for 'csim_set_out'
<stdout>:1904: warning: no previous prototype for 'csim_get_debug'
<stdout>:1909: warning: no previous prototype for 'csim_set_debug'
<stdout>:1943: warning: no previous prototype for 'csim_lex_destroy'
<stdout>:1347: warning: 'yyunput' defined but not used

(In fact, these messages still occur even when building proceeds
successfully. By themselves they are probably not significant.)

Similar messages also appear for imap_cern

4. Compilation continues. At link time, the linker complains of
unresolved references to symbols, which all are csim_* functions.

I cannot reproduce this #4 any more, not even if I downgrade flex to
2.5.31. It just happily links. Maybe the version of flex provided by
synaptic was glitched.
_______________________________________________
Gimp-developer mailing list
Gimp-developer@lists.XCF.Berkeley.EDU
https://lists.XCF.Berkeley.EDU/mailman/listinfo/gimp-developer

Reply via email to