On Wed, 20 Jun 2007 21:54:39 +0200, Raphaël Quinet <[EMAIL PROTECTED]>  

> On Wed, 20 Jun 2007 20:04:01 +0200, [EMAIL PROTECTED] wrote:
>> make maintainer-clean
>> ./autogen.sh
> It would be a good idea to check the contents of config.log at this
> point (or later).  In particular, check that the --prefix argument
> was correctly passed to configure.  You will find how configure
> was invoked in the first few lines of config.log.

I can see as autogen runs it says "I am about to do ...." , I see that the  
prefix is there and the rest of gimp pkg gets put in /opt/gimp , I confirm  
with the datestamp. Multiple checks that this side of things is going as  

>> make && make install
> Maybe it is a stupid question, but did you check that both make and
> make install were successful?

well if make failed make install would not get called. It does get called.

If yes, did you at least check the
> last dozen lines of output from make install to see where stuff was
> being installed?

The only abnormality I noticed was when running this from within kdevelop  
it reported "compilation aborted" implying that it returned a non zero  
condition. No specific error was given. I thought this may be the added  
confusion of using kdev and possibly a result of a bug therein so I fell  
back to using command line std gimp procedures.

Here no error is shown. It ends with this output:

make[2]: Entering directory `/svn/gimp'
test -z "/opt/gimp/bin" || mkdir -p -- "/opt/gimp/bin"
  /usr/bin/install -c 'gimptool-2.0' '/opt/gimp/bin/gimptool-2.0'
test -z "/opt/gimp/lib/pkgconfig" || mkdir -p -- "/opt/gimp/lib/pkgconfig"
  /usr/bin/install -c -m 644 'gimp-2.0.pc'  
  /usr/bin/install -c -m 644 'gimpthumb-2.0.pc'  
  /usr/bin/install -c -m 644 'gimpui-2.0.pc'  
make[2]: Leaving directory `/svn/gimp'
make[1]: Leaving directory `/svn/gimp'

Looks like a normal termination, except we see from the results that  
/opt/gimp/bin/gimp-2.3 is not being installed.

On the face of it all seems to be there and installed as expect. All but  
the program file.


Thanks for you help.
Gimp-developer mailing list

Reply via email to