> > For a long time, nothing has changed in GIMP with respect to XInput
> > devices. So the fact that an upgrade introduced this problem seems to be
> > a strong indication that the problem is elsewhere.
>
> I have similar problems using a Genius tablet. Once I used the pen,
> mouse is no longer detected in the canvas.
> But I think is a GTK+xorg issue and not Gimp's one, because the same
> seems to happen in Inkscape.
> Luis, you should try with inkscape as well (remember to activate the
> tablet as an input device).
> Besides of that, the device driver for my Genius tablet seems to be
> completely broken for GTK apps under Ubuntu Feisty Fawn (it worked in
> the previous version).
> I think it's a GTK problem and not Xorg's one, because MyPaint works
> fine, but gimp and inkscape don't.

I tried to install Inkscape Fedora RPM, but for some reason the last
repository version seems highly broken (at least with my package setup).
I should compile it by myself when I have some time (lots of libraries
and dependencies).

Anyway, your problem description is EXACTLY mine.
Did you try disabling the eraser (not the stylus)?
In that way, the mouse works (but not the eraser, of course).
You should move the stylus to 'activate' the mouse.
Is this also the behavior in Inkscape?

    Thanks,

        L.

_______________________________________________
Gimp-developer mailing list
Gimp-developer@lists.XCF.Berkeley.EDU
https://lists.XCF.Berkeley.EDU/mailman/listinfo/gimp-developer

Reply via email to