2008/3/23, Sven Neumann <[EMAIL PROTECTED]>:
> Sorry, but that is not going to happen. We are not going to expose the
>  interal API to modules or plug-ins as that would make it very hard to do
>  the large changes to the core that are planned for the next development
>  cycles.

I know that it is difficult to expose the API for modules. But as for
"privileged" modules, since it aims to enhance existing code directory from
external modules, when the internal structure changes, framework itself
must be changed. So module developer should know the internal structure
for well.
I think it is responsibility of module developers for
synchronizing its code to the latest version of API so that exposing API
does not prevent to change its interface.

That policy may breaks the compatibility of "privileged" modules, but that
risk is reasonable until the internal structure becomes stable.
If the compatibility matters much, we can introduce some version number
validation protocol to check the incompatibility easily.

But anyway, I will try to list the API which may be accessed from
privileged modules.
Gimp-developer mailing list

Reply via email to