Andrei Simion wrote:
> If one runs a Gimp-Perl script for a number of times, enough to use the 
> whole physical memory, then the Gimp server crashes, it does not create 
> the swap. That's it, no swap file is created.
> I think there may be a configuration issue.
> If a test script is needed I can provide it.

You should add this latest information to the bug report at

If you have a script which demonstrates the problem, attach it to the bug 
report. Note that I said to *attach* the script to the report. Don't just 
paste the script in to the text of the bug report.

In your update, include the version(s) of GIMP you are using, which Linux 
distro (and version) you are using, and the settings of the Preference items 
under "Resource Consumption".

This past weekend I ran some tests using logov1 from inside GIMP and it worked 
perfectly. After each invocation of the script, there was no swap file left 
over. It certainly showed no signs of any leak. Perhaps the problem occurs 
when running a script via the Perl server. I haven't done any rigorous testing 
of running scripts using Perl server yet.


Kevin.           |"What are we going to do today, Borg?"
Owner of Elecraft K2 #2172      |"Same thing we always do, Pinkutus:
                                 |  Try to assimilate the world!"
#include <disclaimer/favourite> |              -Pinkutus & the Borg

Gimp-developer mailing list

Reply via email to