On Mon, 28 Apr 2008 00:01:45 +0000
xsdg <[EMAIL PROTECTED]> wrote:

> Did you make sure to `export LD_LIBRARY_PATH`? (I'm not sure what the 
> equivalent might be for different shells).  This is likely the problem 
> if you see a difference between the output of

Yup. The wrapper script does that, but I've tried doing it by hand as well.

> `ldd /path/to/gimp2.5/bin/gimp`
> and
> `ldd --library-path /path/to/gimp2.5/lib /path/to/gimp2.5/bin/gimp`

ldd reports it linking to /usr/local/lib, so confirming that it's missing the 
target! My version of glibc is 2.3.6 according to ldconfig --version and my 
version of ldd doesn't have the --library-path option.

> Note that you can check for sure if this might be the problem by running 
> gimp2.5 directly with the overridden library path
> `/lib/ld-2.7.so --library-path /path/to/gimp2.5/lib 
> /path/to/gimp2.5/bin/gimp`

I tried that and it still produced the same error. There's something going on 
in the linking stage of gimp I think. I'll try building static libraries only 
and see if that does it.

Gimp-developer mailing list

Reply via email to