Quoting Rob Antonishen <>:

there is such a plugin. I think I saw it in the Meet the Gimp forums.

I wrote the following script a while back for a coin collector who wanted to easily crop his scans and rotate them so that the coin was oriented properly.

The interface I used was to click-drag a path from the top of the coin to the bottom. The resulting path had only one anchor (at the coin's top) but the control handle was used as the second point.

The script would require some modification but might provide a kludgy functionality for those needing it.

A discussion over the evolution of the script took place on the GIMPtalk forums:
Not sure whether its transient or permanent but above URL gives:

   SQL ERROR [ mysql4 ]
   Table './gimptalk_lbsql/phpbb_sessions' is marked as crashed and
   should be repaired [145]
   An sql error occurred while fetching this page. Please contact an
   administrator if this problem persists.

I found it in Google-cache at: or:

I grabbed your script from flashingtwelve.brickfilms URL above, set a path with Path tool and when I ran it (GIMP 2.6.6 - Windows XP SP3) got this in the error console:

     GIMP Error
   Calling error for procedure 'gimp-image-crop':
   Procedure 'gimp-image-crop' has been called with value '-160' for
   argument 'offx' (#4, type GimpInt32). This value is out of range.

     GIMP Warning
   Plug-In 'Rotate To Path Point' left image undo in inconsistent
   state, closing open undo groups.

     GIMP Error
   Execution error for 'Rotate To Path Point':
   Error: Procedure execution of gimp-image-crop failed on invalid
   input arguments: Procedure 'gimp-image-crop' has been called with
   value '-160' for argument 'offx' (#4, type GimpInt32). This value is
   out of range.

I notice that at the bottom of the original conversation the OP (StefanP) has a recent unanswered problem (Sun Apr 26, 2009 2:18 am) after updating to GIMP 2.6 (not exactly the same error as I got):

   It is me again. After upgrading to Ubuntu 9.04 and Gimp 2.6 I am now
   getting the following error after setting the path and executing the

   Execution error for 'Rotate To Path Point':
   Error: Bad syntax of binding spec in let* : ((vectors) (stroke-id)
   (points) (x1) (y1) (x2) (y2) (center-x) (center-y) (radius) (angle)
   (foo (car (gimp-image-get-filename image))))

Regards ... Alec   (bura...@gmail & WinLiveMess - alec.m.burg...@skype)

Gimp-developer mailing list

Reply via email to