I've been trying to debug invoking my gimp plug-in from an apache
module for past 3 days without much success.
I'm sure others tried the same, but Google didn't help much in finding
these gems, so far.
So maybe a fresh pair of eyeballs may have other ideas ...

Ok, basically, I have a python-based GIMP plug-in which runs Ok when
invoked from command-line.
But when called from apache (from a python-based apache
plugin/module), for some reason the command:

gimp --no-interface --batch='(python-fu-pdf2jpg RUN-NONINTERACTIVE
"/path/to/image/to/proces.pdf" )'  --batch='(gimp-quit 1)'

doesn't get executed. Or it does but fails silently - which is not
very helpful here !!

For testing, I've set the permissions of the OUTPUT directory
to 'www-data' (apache user) and '777' (open to universe) but still got no output
from the GIMP plug-in in this directory.
... though I got debugging files written by the apache module,
so I know apache can write can write files in this directory at run-time.

But nothing from the Gimp module ...
Actually I don't get ANY error message from GIMP in any of my /var/log files
But once again,  if I run that Gimp command from the command line
(bash), it runs Ok !!
This would suggest a permissions problem, but I'm not sure.
I wonder: does Gimp need to write to the user home directory by any chance?
In that case, 'www-data' (the apache user) doesn't have a home
directory per se.

So after 3 days of trying different options and digging the Web,
I'm a little out of 'debug tricks' right now. If anyone knows why Gimp
keeps silent
or knows of a mailing list thread which discusses this topic (i.e.
Gimp web invocation),
I would very much appreciate it.

Gimp-developer mailing list

Reply via email to