On Sat, Oct 3, 2009 at 4:27 PM, Alexia Death <alexiade...@gmail.com> wrote:
> On Sat, Oct 3, 2009 at 10:02 PM, Chris Mohler <cr33...@gmail.com> wrote:
>> On Sat, Oct 3, 2009 at 1:54 PM, Chris Mohler <cr33...@gmail.com> wrote:
>>> Not sure how best to proceed - GIMP is requiring libgtk 2.16.6 to
>>> proceed, and Ubuntu 9.04 is shipping 2.16.1.

>> Compiling 2.16.6 now, sticking in /opt...
> you probably should remove any *.la files from your /usr/lib, or you
> will run into a bad dependency/libtool hell. Happened to me after
> installing gtk from git, and I was told this is common.

Well, I installed gtk 2.16.6 into /opt/gtk, then exported my
LD_CONFIG_PATH to there before compiling gimp (and also added to
PKG_CONFIG_PATH), so hopefully I've sidestepped that.  If I'm headed
for trouble with this approach, someone please let me know :)

It seems to be working OK, but it's not picking up the current GTK
settings/devices (like tablet).  I think this method will work well
enough for testing purposes though, and my stock 2.6.6 install seems
to be working just fine.

Gimp-developer mailing list

Reply via email to