On Wed, 2010-03-17 at 22:49 +0100, Emil Assarsson wrote:
> Hi,
> 
> I can't build Gimp from the git:
> 
> Making all in libgimpwidgets
> make[2]: Entering directory `/home/emil/gimp-build/gimp/libgimpwidgets'
>   CC     gimpstock.lo
> gimpstock.c:394: error: ‘stock_input_device_22’ undeclared here (not
> in a function)
> gimpstock.c:521: error: ‘stock_input_device_16’ undeclared here (not
> in a function)
> gimpstock.c:521: error: initializer element is not constant
> gimpstock.c:521: error: (near initialization for
> ‘gimp_stock_menu_pixbufs[24].inline_data’)
> make[2]: *** [gimpstock.lo] Fel 1
> make[2]: Leaving directory `/home/emil/gimp-build/gimp/libgimpwidgets'
> make[1]: *** [all-recursive] Fel 1
> make[1]: Leaving directory `/home/emil/gimp-build/gimp'
> make: *** [all] Fel 2
> 
> Do I need to upgrade xorg or something?

No, you need to *always* use autogen.sh and *never* configure directly
when you build from git (as opposed to tarball).

--mitch


_______________________________________________
Gimp-developer mailing list
Gimp-developer@lists.XCF.Berkeley.EDU
https://lists.XCF.Berkeley.EDU/mailman/listinfo/gimp-developer

Reply via email to