On Tue, 2010-07-06 at 12:08 -0700, BugByteMan wrote:
> GIMP (git) is not currently compatible with gtk+2.90.x versions (gtk
> +-3.0).
> The first error I ran into is the use of deprecated functions:
>   CC     gimpbrowser.lo
> In file included from gimpwidgets.h:75:0,
>                  from gimpbrowser.c:30:
> ../libgimpwidgets/gimpunitmenu.h:48:3: error: expected
> specifier-qualifier-list before 'GtkOptionMenu'
> ../libgimpwidgets/gimpunitmenu.h:65:3: error: expected
> specifier-qualifier-list before 'GtkOptionMenuClass'
> make: *** [gimpbrowser.lo] Error 1
> What are the plans to make GIMP (git) compatible with the gtk+?

GIMP 2.x is a GTK+ 2.x application,
GIMP 3.x will be a GTK+ 3.x application.

We guarantee the same API and ABI compatibility
for our plug-ins as GTK+ does, so we can't move
to GTK+ 2.90 now.

After GIMP 2.8 (which will use GTK+ 2.22) is out, we
will move to GTK+ 3.x (and thus GIMP 3.x).

Besides, why are you bulding GIMP against GTK+ git
master anyway, GTK+ master is currently not good
for anything but developing GTK+ 3.0 itself, and
porting applications to it. You should stick with
the gtk-2-22 branch if you want bleeding edge of
the GTK+ you are used to.


Gimp-developer mailing list

Reply via email to