On Fri, 2011-02-11 at 14:02 +0200, Alexander Rabtchevich wrote:
> No needs to apologize, it's a work in progress
> Another question here - is there a plugin conversion guide somewhere? I 
> tried to run wavelet-sharpen plugin, compiled for 2.7, but it fails with 
> 2 messages:
> Could not execute plug-in "wavelet-sharpen"
> (/opt/gimp-2.7/lib/gimp/2.0/plug-ins/wavelet-sharpen)
> because it uses an obsolete version of the plug-in protocol.

All plugins are binary-compatible within the 2.x series,
the error you are seeing is because your plugin still
links to an old libgimp version installed somewhere,
and libgimp and the gimp app can only work together
within one protocol version.

Make sure your plugins find the right libgimp and
everything will be fine.


Gimp-developer mailing list

Reply via email to