I'm building the prerequisites on F14 in order to build GIMP from GIT.
It appears all prerequisites are now required to be built on F14 so I'm
doing these:
babl gegl glib atk pango gdk-pixbuf gtk+ gimp

Everything goes well till I get to the GTK+ install phase.  It's giving
me the following:

make[3]: Leaving directory `/home/mjhammel/src/graphics/gimp/git/gtk
Making install in .
make[3]: Entering directory `/home/mjhammel/src/graphics/gimp/git/gtk
/usr/bin/g-ir-compiler --includedir=. --includedir=. --includedir=.
Gdk-2.0.gir -o Gdk-2.0.typelib
Gdk-2.0.gir: error: Type reference 'GdkPixbuf' not found
make[3]: *** [Gdk-2.0.typelib] Error 1

I've built and installed the prerequisites, including gdk-pixbuf,
to /usr/local/gimpgit.  I've tried building gobject-introspection but
that doesn't build either.  I didn't think that was required for pre-3.0
anyway (side note: should latest GIMP GIT build with 3.0?).  I was under
the impression that the "gir" stuff was from the introspection stuff,
but maybe not.

My build command looks like this:
PKG_CONFIG_PATH=/usr/local/gimpgit/lib/pkgconfig/ \
XDG_DATA_DIRS=/usr/local/gimpgit/share/ \
LDFLAGS=-L/usr/local/gimpgit/lib \
CFLAGS=-I/usr/local/gimpgit/include \

Some of this is overkill - I have more cleanup to do in my latest build

I'm building gtk+ 2.24.3 since GIMP's INSTALL references this and have
tried up to 2.24.5.  All give the same error.

Just wanted to check if anyone else had seen this before asking on the
GTK+ list.

Michael J. Hammel <mjham...@graphics-muse.org>

Gimp-developer mailing list

Reply via email to