On Wed, Feb 02, 2000 at 03:05:30PM -0500, Tom Rathborne <[EMAIL PROTECTED]> wrote:
> This is probably a generic automake/pgcc problem, but it's exhibiting
> itself with the GIMP first, so here it is:

Slow, slow... _what_ is breaking? What are you compiling?

> my ld supported emulations. I'm using pgcc 2.95.3, and ld is:
>     GNU ld version 2.9.5 (with BFD 2.9.5.0.24)
> The relevant line from ld's output output is:
>     ld: supported emulations: elf_i386 i386linux

I have:

cerebro:~/src/Gimp# ld --version
GNU ld 2.9.5
Copyright 1997 Free Software Foundation, Inc.
This program is free software; you may redistribute it under the terms of
the GNU General Public License.  This program has absolutely no warranty.
  Supported emulations:
   elf_i386
   i386linux
   i386go32
   elf32ppclinux
   elf32ppc
   elf64alpha
   alpha

> It seems that config.guess only checks the _first_ listed emulation,

which config.guess. From gimp?

cerebro:~/cvs/gnome/gimp# ./config.guess
i686-pc-linux-gnu

works for me..

> elf_i386)
>     echo "${UNAME_MACHINE}-pc-linux-gnuaout"
>     exit 0
>     ;;
> 
> Am I doing something wrong - other than using bleeding-edge pgcc and

Well, elf_i386 and a.out definitely do not go together.

Do you have an a.out-based system??

-- 
      -----==-                                             |
      ----==-- _                                           |
      ---==---(_)__  __ ____  __       Marc Lehmann      +--
      --==---/ / _ \/ // /\ \/ /       [EMAIL PROTECTED] |e|
      -=====/_/_//_/\_,_/ /_/\_\       XX11-RIPE         --+
    The choice of a GNU generation                       |
                                                         |

Reply via email to