On 23 Feb, Sven Neumann wrote:

> gimp_plugin_add_locale_domain (gchar *domain_name,
>                              gchar *domain_path)
 
> and can only be called in the query function of a plug-in. The
> domain_path may optionally be NULL. Proposals for a better name are
> welcome.

 I'd recommend gimp_plugin_domain_add (gchar *domain_name)
 and gimp_plugin_domain_add_with_path (gchar *domain_name,
                                       gchar *domain_path)

 because it IMHO fits better into the namespace and is more obvious
 than to have just 1 function with two meanings.
 
> Daniel, if we can agree on this solution, I would like to check this
> code in, so that you can work on adapting your code to the framework.

 I sent a newer patch in my last mail. It should do everything we need
 for now.

 I totally agree with this solution, so let's finalize it and get it
 into the tree.

> While working on the code I came across a new idea which would
> simplify things quite a bit eventually: The plugins create their
> menu_entry in app/plug_in.c in the function plug_in_make_menu (). Why
> not use the knowledge about the domain_name the translated string is
> to be found in and only look it up in that domain by passing it to
> menus_create_item_() ? You'd only have to change the code to iterate
> through the plug_in_defs instead of proc_defs since the domain is
> stored with the plug_in definition.

 I'm afraid I don't understand that. Could you please explain it again?

-- 

Servus,
       Daniel

Reply via email to