In regard to: Re: gimp 1.1.18, Garry R. Osgood said (at 9:16pm on Mar 24, 2000):

>> <snipped...>
>> - on alpha-dec-osf4.0d, the program give all errors when loading
>>   plugins even though plugin does not crash::
>>  $  /usr/local/bin/gimp
>> ** WARNING **: wire_read: error
>> ** WARNING **: wire_read: error
>> ** WARNING **: wire_read: error
>> ** WARNING **: wire_read: error
>> ....
>> $ /usr/local/lib/gimp/1.1/plug-ins/align_layers
>> /usr/local/lib/gimp/1.1/plug-ins/align_layers is a gimp plug-in and must be run by 
>the gimp to be used
>This appears to be a curious manifestation of #2742, which has been pestering
>DEC Alpha people since October (see
>What makes this curious and troublesome was that people seemed to be having
>trouble with compiler version 4.0.F, and reverting to 4.0.D was the workaround.
>You appear to be having trouble with 4.0.D.
>One individual upgraded to 5.0 and reported a clean compile.

I've seen this at various times on all the alpha-dec-osf boxes I'ved tried
compiling gimp on -- I think I may have been the first person to report it
to the developer list.  At various times I've thought the problem had been
fixed by some change in the gimp, but I just tried 1.1.19 on a 5.0 box with
patch set #1 last weekend, and the same thing happened.  I have a 4.0f box
that the problem doesn't happen for though.

As I mentioned when I first reported this problem, it turns out that if you
run the gimp under `trace' (just like truss) the first time you run the gimp,
most of the plug-ins are queried successfully and work as expected thereafter.
At that point, you can run gimp without tracing it, and the plugins work fine.
It's only the first time through that this happens.

It's definitely an odd problem.  If anyone has any suggestions for how to
debug it, please let me know.   I would be willing to help.

Tim Mooney                              [EMAIL PROTECTED]
Information Technology Services         (701) 231-1076 (Voice)
Room 242-J1, IACC Building              (701) 231-8541 (Fax)
North Dakota State University, Fargo, ND 58105-5164

Reply via email to