The following has happened with all gimps after 1.1.18,
even 1.1.20. I have now found the cause. 
After doing a successful ./configure
"make" gives the following:
Making all in po
      make[2]: Entering `/home/winters/gimp-1.1.18/po'
      make[2]: *** No rule to make target `en.gmo', needed by  `all-yes'. Stop.
      make[2]: Leaving directory `/home/winters/gimp-1.1.18/po'
      make[1]: *** [all-recursive] Error 1
      make[1]: Leaving directory `/home/winters/gimp-1.1.18'
      make: *** [all-recursive-am] Error 2

(error actually taken from Jon Winters post to the list, 
but mine was identical except for directories names) 

The reason is something in my system (gnome,enlightenment,
or maybe gdm) sets the variable LINGUAS to en . Gimp has
nothing in its localization for that so the compilation

A check in the configure file for this would be useful. 
I guess the cleanest would be that if LINGUAS variable is
not recognized it should default to english and not give 
any other problems. 

In the meantime, maybe adding this to the readme would be
useful. I solved it by setting doing "unsetenv LINGUAS"

To repeat:
setenv LINGUAS (to something not in the .po .gmo files, en)
and run ./configure, make

Great work!

Reply via email to