I found some strange errors while configuring Gimp-Perl in 1.1.29.
The previous versions worked fine (1.1.25 and 1.1.26 from tarball,
1.1.27 and 1.1.28 patched from previous version) so this looks like a
new error.

What happened was that perl could not find the required modules (PDL,
Perl-Gtk, Parse::RecDescent) although they were installed correctly
and were working with all recent versions of the Gimp.  After a bit of
investigation, I discovered that the perl configuration script was not
using the right version of Perl!  Instead of taking /Local/bin/perl
which is listed first in my path and has all the required modules
installed, it was taking /opt/local/perl5/bin/perl which comes later
in my path.  This older perl executable is also symlinked from
/bin/perl and /usr/bin/perl, but all these directories come after
/Local/bin.

Here is the output from the top-level configure script, which also
shows another problem with a missing Makefile in devel-docs/pdb/:

[...]
creating devel-docs/libgimp/Makefile
creating devel-docs/pdb/Makefile
Can't open ./devel-docs/pdb/Makefile.in
creating data/Makefile
creating data/brushes/Makefile
[...]
creating help/images/Makefile
creating config.h
invoking perl for configuration...

WARNING: unable to use PDL (the perl data language). This means that
         normal pixel access is non-functional. Unless you plan to use
         Tile/PixelRgn functions together with PDL, this is harmless. The
         plug-ins using PDL, however, will NOT WORK and you can NO LONGER
         install PDL later. You can get PDL from any CPAN mirror.

checking for PDL support... no

NOTICE:  You are using a version of perl older than 5.005. This will slightly
         reduce the features available to the Gimp-Perl extension.


NOTICE:  unable to use the Perl-Gtk interface. Many features (like
         Gimp::Fu) rely on this extension. You can build without it (and
         many scripts will be disabled or run with reduced functionality
         only), but it's better to install it (version 0.6123 or higher is
         required, you can get it from ftp://ftp.gimp.org/pub/gtk/perl/ or
         any CPAN mirror.


NOTICE: Parse::RecDescent not found, scm2perl, the Scheme->Perl
        translator, will not work. This is normally not a problem, since
        it is quite unimportant for most people.

building embedded perl module... no
writing Gimp/Config.pm... ok
Checking if your kit is complete...
Warning: the following files are missing in your kit:
        po/Makefile.PL
        po/update.sh
Please inform the author.
Warning: prerequisite Gtk 0.5 not found at (eval 4) line 221.
Warning: prerequisite PDL 1.99 not found at (eval 4) line 221.
Warning: prerequisite Parse::RecDescent 1.6 not found at (eval 4) line 221.
Writing Makefile for Gimp::Lib
Writing Makefile for Gimp::Net
Note (probably harmless): No library found for -lgimp
Writing Makefile for Gimp::UI
Writing Makefile for Gimp
[...]


I do not understand why this happened.  Going to the perl plug-in
directory and typing "make distclean; perl Makefile.PL; make" seemed
to solve the problem, but configuring from a freshly extracted tar
file did not work.

-Raphael

P.S.: Thanks to Simon for the splash screen.  I will still try to
      finish and upload mine in case we ever need a 1.1.30.

Reply via email to