[EMAIL PROTECTED] (Raphael Quinet) writes:

> On Fri, 10 Nov 2000, David Monniaux <[EMAIL PROTECTED]> wrote:
> > I compiled Gimp under Solaris with --with-included-gettext. Trying to run
> > it with LANG=fr... does not yield anything translated. Nevertheless, Gimp
> > seems to load the translation file (seen in strace).
> > 
> > Has anyone else noticed this behavior, or is it my setup?
> I compiled Gimp 1.1.29 under Solaris 2.6 without the included gettext
> (I have GNU gettext 0.10.35 installed in my path, and "configure" is
> happy with it).  I had never tried to set LANG=fr under Solaris, so I
> just tried to see if I had any problems.  Well, I got the answer in
> less than 2 seconds...
> csh> setenv LANG fr
> csh> gimp

Ehm, this is AFAIK not a valid locale setting.

LC_ALL=fr_FR gimp



works fine for me.

OTOH it took me days to get the beast running on Solaris and I don't
know if my working locale stuff comes from some mystic environment
variables that were set when compiling gtk+ and gimp. (there are
lots of mystic variables set in the university's heterogeneous
network) ;)

Another important point to mention is that GIMP wants to be compiled
with the same version of gettext that GTK was compiled with,
which should not be solaris gettext (didn't work for me) but
GNU gettext.

So compiling GTK with some GNU gettext lying around (not linking
against it because that's the job of the app which links against
GTK) _and_ GIMP with --with-included-gettext should do the job
because then GTK will use the GNU gettext that ships with the
GIMP tarball.


Reply via email to