Martin Edlman ([EMAIL PROTECTED]) wrote:
> Simon Budig wrote:
> > Hmm - it is definitely too late to change the Api to rename this
> > function to "gimp_layer_offsets". But is there a special reason why this
> One way to make it sensefull and put gimp_layer_offsets to the API is to
> rename the function and then
> #define gimp_drawable_offsets(id,x,y) gimp_layer_offsets(id,x,y)
> or withou renaming the function just
> #define gimp_layer_offsets(id,x,y) gimp_drawable_offsets(id,x,y)
> You keep compatibility and make happy those who want
> gimp_layer_offsets();

No. You have to change it in the PDB, where those #defines are
useless (they would only work inside libgimp). However, this problem
is not a technical one. I just wanted to know, if there is a *reason*
why this funcion is named oddly.


Reply via email to