On Thu, Dec 28, 2000 at 06:42:40PM +0530, Chetan Dhavse <[EMAIL PROTECTED]> wrote:
> Subroutine gimp_text_get_extents_fontname redefined at 
>/opt/other/src/perl-5.6.0/lib/site_perl/5.6.0/i686-linux/Gimp.pm line 539.
> Subroutine gimp_bucket_fill redefined at 
>/opt/other/src/perl-5.6.0/lib/site_perl/5.6.0/i686-linux/Gimp.pm line 539.
> Sorry but I am lost. The same warnings are for almost all the function

this is very strange but is most probably a problem with your script
(double fork or something similar) - how do you start your script, and can
you send a stripped-down version of your script that shows this error?

> The plug in "plug_in_autocrop" gives the following error if I use
> plug_in_autocrop(1,$img,$layer); (as mentioned in DB browers)

Certainly this is nowhere mentioned in DB browers, where did you get the "1"
from? Hardcoding constants is going to bite you. Either use
RUN_NONINTERACTIVE (or RUN_INTERACTIVE) or, better, just leave our the
unnecessary arguments, e.g.:


or even


> but works fine if I use
> plug_in_autocrop(1,$layer);

Because 1 happens to be a valid image id. The first agrument is the
run_mode, which must be on the the three symbolic RUN_*-constants. The
second agrument must be an image and the third a layer. It happens thta
you can leave out the first two agruments, since they are redundant (no
runmode == noninteractive and a layer always belongs to some image).

This could also solve your problems above, since 5.6.0 is rather broken
with regards to error handling (this has been fixed in later snapshots, so
best use 5.005_03 or a current perl snapshot if you want sensible error
reporting) so the above could just be the effect of a runtime error that
doers not get reported but instead garbles perl's internal state.

      -----==-                                             |
      ----==-- _                                           |
      ---==---(_)__  __ ____  __       Marc Lehmann      +--
      --==---/ / _ \/ // /\ \/ /       [EMAIL PROTECTED] |e|
      -=====/_/_//_/\_,_/ /_/\_\       XX11-RIPE         --+
    The choice of a GNU generation                       |

Reply via email to