I'm trying to build 2.8 on freebsd.
As a starting point, I'm trying to build only babl-0.1.10
I've downloaded the tarball and unpacked it.
  cd /usr/local
  mkdir -p gimp-2.8/lib/pkgconfig
  mkdir gimp-2.8/bin
  export PATH=/usr/local/gimp-2.8/bin:$PATH
  export PKG_CONFIG_PATH=/usr/local/gimp-2.8/lib/pkgconfig
  export LD_LIBRARY_PATH=/usr/local/gimp-2.8/lib
  cd ~/Computing/GIMP/work_2.8/babl-0.1.10
  ./autogen.sh --prefix=/usr/local/gimp-2.8

  make  all-recursive
  Making all in babl
  "Makefile", line 1013: Missing dependency operator
  make: fatal errors encountered -- cannot continue

babl/Makefile line 1012-103 looks like this:

# GObject Introspection

INTROSPECTION_MAKEFILE is set empty early on in babl/Makefile

It is also set empty in the top level Makefile, 
along with all the other INTROSPECTION_* symbols
plus a few others like LDFLAGS and LIBOBJS

I'm guessing there's something additional I need to do either in terms
of flags passed to make or autogen, or else some environment vars needed
to get the gnome build environment correct.



gimp-user-list mailing list

Reply via email to