i compiled gimp. 2.8 on my ubuntu according: 
http://www.gimpusers.com/tutorials/compiling-gimp-for-ubuntu
Now i want to write my own (C++) plug-in and tried this as a start: 
http://developer.gimp.org/writing-a-plug-in/1/index.html

But it complains - i get an error message:
----------------------------------------
Hello world Message
Could not execute plug-in "hello"
(/home/frank/.gimp-2.8/plug-ins/hello)
because it uses an obsolete version of the plug-in protocol.

GIMP Message

Plug-in crashed: "hello"
(/home/frank/.gimp-2.8/plug-ins/hello)

The dying plug-in may have messed up GIMP's internal state. You may want to save
your images and restart GIMP to be on the safe side.
----------------------------------------

Where can i get some example, which is according the current interface
definitions.
Preferrable some, which actually does some simple image processing, e.g. mirror
picture.

- many thanks!

best regards,
Frank

-- 
FBergemann (via www.gimpusers.com/forums)
_______________________________________________
gimp-user-list mailing list
gimp-user-list@gnome.org
https://mail.gnome.org/mailman/listinfo/gimp-user-list

Reply via email to