i've got a strange problem: when zooming images in the GIMP (2.8.2, installed from archlinux [extra]), viewing them larger than the size they are being automatically zoomed to by default, they break up into unconnected, rectangular tiles.

moving (panning) them around with the mouse so that they partially leave the screen brings those parts back to be displayed properly. means i have to 'swivel' the image across all borders to get it to display properly.

in addition, applying scissors or path tool leaves artefacts on the image that can be removed the same way.

i've noticed this first with the development version of GIMP (2.9, compiled from GIT) and thought those were the new GIMP's growing pains -- but then i noticed the same happening with the stable version (2.8).

i've tried switching to an earlier version of xf86-video-ati and to an earlier kernel, but neither rectifies the problem. i also tried different options in /etc/X11/xorg.conf.d/ 20-radeon.conf, whith the same result, i.e., none.

seems to have something to do with the image being refreshed, or not being refreshed, but which part of the system is at fault baffles me.

i'm using arch +testing, and here are my system's details:

System: Host: laptop Kernel: 3.7.3-1-ARCH x86_64 (64 bit) Desktop: KDE 4.9.98 Distro: Arch Linux Machine: Mobo: ASUSTeK model: K53SK version: 1.0 serial: BSN12345678901234567
Bios: American Megatrends version: K53SK.203 date: 10/11/2011
CPU: Quad core Intel Core i7-2670QM CPU (HT-MCP) clocked at 800.00 MHz
Graphics: Card-1: Intel 2nd Generation Core Processor Family Integrated Graphics Controller Card-2: Advanced Micro Devices [AMD] nee ATI Whistler LE [AMD Radeon HD 6625M Graphics]
X.org: 1.13.1 drivers: ati,radeon,intel tty size: 114x37

gimp-user-list mailing list

Reply via email to