C210LUV wrote:
Before deleting your EXIF data, can you post an example image that can
be
tested by others?


Sorry this took so long, was trying to figure a way to reduce the size of the
image without being able to use GIMP, so I just did an arbitrary crop of one of
the images in question. Attached is one image in a series taken to eventually be
merged together, cropped for upload size and still unable to be opened using
GIMP.

I downloaded a program called Exiftool  to try to remove Exif data, but the
language is way over my head and I haven't even tried.

Attachments:
* http://www.gimpusers.com/system/attachments/146/original/052.JPG

I realise C210LUV has solved the immediate problem by installing the 64-bit version of a different build, but for what it's worth I am NOT able to open the above 052.JPG using:
- Windows Vista 32-bit
- GIMP 2.8.10 downloaded from gimp.org

After removing metadata with:
  exiftool -all= 052.jpg
as suggested by others, the file opens in GIMP without any problem, so it does appear related to the metadata.

Steps to reproduce with the original file:
- Start GIMP
- File > Open
- Browse to the folder containing 052.JPG (C:\Users\Mark\Documents\aTemp\2014-08-20-GIMP-Test\)
- Click on 052.JPG; a thumbnail is shown in the preview
- Click "Open"

The "Open Image" dialog becomes mostly greyed out, with only the "Help" and "Cancel" buttons left active, and is still in that state after waiting several minutes. The "Help" button brings up the help as usual; "Cancel" stops one of the child processes (see below) but not the other, and the dialog remains open and greyed out (no apparent effect to the user). The main image window (with no image loaded) remains responsive, and closing that closes GIMP, all child processes and the "Open Image" dialog.

In case it helps, Process Explorer shows that, on clicking the "Open" button in the "Open Image" dialog, file-jpeg.exe and metadata.exe are started as child processes of gimp-2.8.exe. metadata.exe is taking ~50% CPU and ~11MB memory, even after several minutes. Clicking "Cancel" stops file-jpeg.exe, but metadata.exe continues at ~50% CPU (and as mentioned above, the dialog remains open and greyed out). I have a dual-core CPU, so ~50% is probably all available capacity on one core.

No messages are shown in GIMP's error console.

Should this be reported as a bug? Even if there is something invalid about the metadata, presumably this should result in an error or warning, rather than just hanging the "Open Image" dialog?

Mark.
_______________________________________________
gimp-user-list mailing list
List address:    gimp-user-list@gnome.org
List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list
List archives:   https://mail.gnome.org/archives/gimp-user-list

Reply via email to