Hello Paul,
Thanks for your feedback.  I'm not sure if you meant to reply off-list but
I'll include the mailing lists in my reply.  Hope you don't mind.

On Sun, Sep 27, 2015 at 3:39 PM, Paul Alkhimov <alkhi...@gmail.com> wrote:

> *TL;DR*: it did not work out and I have no idea where to find the gimp
> sources in the vm.

It should have cloned GIMP source in the following steps (upon typing
"vagrant up").


> I attach the log copied directly from the terminal. In this way you can
> see the way your solution is used by a random person. My approach is to try
> first is everything works and then, if necessary - to fix the stuff.
> So, here is what I did:
> 1. Read your e-mail, read the readme.md at
> https://github.com/samrocketman/vagrant-gimp
> 2. git clone https://github.com/samrocketman/vagrant-gimp.git (SUCCESS)
> 3. cd vagrant-gimp && vagrant up (FAILURE: "The program 'vagrant' is
> currently not installed.")
> 4. sudo apt-get install vagrant (OK)
> 5. vagrant up (FAILURE: "Vagrant could not detect VirtualBox")
> 6. sudo apt-get install virtualbox (OK)
> 7. vagrant up (FAILURE: vm: * The box 'debian/jessie64' could not be
> found.)
> 8. as the error looked strange, I went to the vagrant site and installed
> the latest provided version=1.7.4. (OK)
> *COMMENT*: up to this step I had the problems with wrong version of the
> vagrant. I accept that I ignored your first instruction in the e-mail ( 1.
> Install vagrant https://www.vagrantup.com/), but on the other hand,
> neither this e-mail, nor github repo mentioned that I absolutely must use
> the latest version from the site instead of the provided by the system => I
> wrongly supposed that any version is ok.

I have incorporated your feedback into the README.  See the section at the
top for prerequisites.

> 9. vagrant up (FAILURE: "Atlas push: * Missing required configuration
> parameter 'token'....")
> 10. tried vagrant login with provided vagrant/gimp pair (FAILURE)
> 11. registered on https://atlas.hashicorp.com/ (OK)
> 12. vagrant login (OK)
> *COMMENT*: these mistakes are also stupid for those who know what vagrant
> is, but for others I believe this behavior can be completely logical.

These mistakes are not stupid and an account at hashicorp should not have
been a barrier to entry.  I have updated the bootstrapping process and
removed this requirement.

> 13. vagrant up (OK, but it was not extremely fast on my 8MBit connection)
> 14. I tried to log in into the running system, but did not succeed for
> unknown reason (FAILURE)
> 15. shutdown the vm with "sudo shutdown" and vagrant reload (OK)
> 16. could not find the GIMP sources => *FAILURE*
> In fact I found the scripts in setup/gimp-packages/ and other folders, but
> I don't know where the sources actually are. You say "There should the
> following files and directories in the vagrant user.
>    - ~/gimp-git - contains all of the output from the gimp build.
>    - ~/gimp-git/share/config.site - a file containing variables used by
>    the build process.
>    - ~/git/babl - source code of BABL
>    - ~/git/gegl - source code of GEGL
>    - ~/git/gimp - source code of GIMP
>    - ~/build-gimp.sh - a script to compile BABL, GEGL, and GIMP all at
>    once."
> But they are just not there.
> // I attach a complete host log if it helps.

After reviewing your log it appears the bootstrap failed due to an
out-of-date package.  I'll work on bootstrapping again to ensure that it is
fixed.  It's quite possible Debian Jessie removed the package.  Here's the
excerpt from the log.

==> default: Package libjpeg8-dev is not available, but is referred to by
another package.
==> default: This may mean that the package is missing, has been obsoleted,
==> default: is only available from another source
==> default: However the following packages replace it:
==> default:   libjpeg62-turbo-dev
==> default: E
==> default: :
==> default: Package 'libjpeg8-dev' has no installation candidate
==> default: + apt-get update --fix-missing
==> default: Hit http://security.debian.org jessie/updates InRelease
==> default: Hit http://security.debian.org jessie/updates/main Sources
==> default: Hit http://security.debian.org jessie/updates/main amd64
==> default: Hit http://security.debian.org jessie/updates/main
==> default: Ign http://httpredir.debian.org jessie InRelease
==> default: Get:1 http://httpredir.debian.org jessie Release.gpg [2,373 B]
==> default: Hit http://httpredir.debian.org jessie Release
==> default: Get:2 http://httpredir.debian.org jessie/main Sources [7,058
==> default: Get:3 http://httpredir.debian.org jessie/main amd64 Packages
[6,764 kB]
==> default: Get:4 http://httpredir.debian.org jessie/main Translation-en
[4,585 kB]
paul>brix>~>Development  vagrant-gimp>master>$>vagrant reload

It should have properly alerted you with a failure message.  I'll work on
ensuring the failure message properly surfaces an issue.

> My conclusion on this approach currently is following: I need to somehow
> understand Vagrant to use it at all. And still, the result is not
> cross-platform, for instance I cannot build for Windows. So a snapshot of
> the VM is completely enough, it is only huge normally, but OTOH it can be
> done in the background and it is complete no-brainer.

My hope is that the knowledge of vagrant required is very little other than
installing vagrant and typing the commands outlined in the README.

I'll follow up with when I believe the bootstrapping process is fixed.


I prefer to encrypt my email

8D8B F0E2 42D8 A068 572E
BF3C E8F7 3234 7257 E65F

Learn how to encrypt your email with the Email Self Defense guide:
gimp-user-list mailing list
List address:    gimp-user-list@gnome.org
List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list
List archives:   https://mail.gnome.org/archives/gimp-user-list

Reply via email to