Hi,

Have a look at the builtin procedure browser, to be found in the help menu. You should find both the deprecated and the replacing procedures there. If you have a little programming background, you can adapt the scripts yourself. I did this recently for a few scripts that didn't work correctly in v2.9.1 ("Straighten & Crop" and "Shadow & Highlight").


In 2.9.1 (Partha's version) I found that the python translations are not always working correctly. I haven't figured out what/why on that.

Op 18-10-2015 om 12:25 schreef Helmut Jarausch:
Hi,

from time to time I get deprecation warnings in older script-fu scripts.
Like
gimp-selection-load should be replaced by gimp-image-select-item

but gimp-image-select-item always takes 3 parameters while gimp-selection-load 
had been called with a single parameter.

Is there an upgrade guide for script-fu scripts?

Many thanks for a pointer,
Helmut



_______________________________________________
gimp-user-list mailing list
List address:    gimp-user-list@gnome.org
List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list
List archives:   https://mail.gnome.org/archives/gimp-user-list

_______________________________________________
gimp-user-list mailing list
List address:    gimp-user-list@gnome.org
List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list
List archives:   https://mail.gnome.org/archives/gimp-user-list

Reply via email to