That is what I thought. Clearly something is wrong, but I am unable to 
identify the error. How, do I pass in a list of characters? GIMP 
complains when I try to pass in a list object. I have tried everything, 
I can think of. 

Thanks.


>----Original Message----
>From: ke...@ve3syb.ca
>Date: 20/03/2016 02:55
>To: <gimp-user-list@gnome.org>
>Subj: Re: [Gimp-user] debugging script-fu with list-&gt;string
>
>On 16-03-14 09:56 AM, uga...@talktalk.net wrote:
>> I believe Script-fu supports list->string but I may be mistaken. I 
am
>> unable to get it to work. E.g. (gimp-message (list->string '(0 0 0) 
))
>> returns Error: ( : 2) string-set!: argument 3 must be: character
>
>list->string is defined in the script-fu.init file. It takes a list 
of 
>characters and returns a newly allocated string from formed form the 
>characters in the list.
>
>This is in accordance with the R5RS document (see page 30).
>
>-- 
>Cheers!
>
>Kevin.
>
>http://www.ve3syb.ca/           |"Nerds make the shiny things that 
distract
>Owner of Elecraft K2 #2172      | the mouth-breathers, and that's why 
we're
>                                 | powerful!"
>#include <disclaimer/favourite> |             --Chris Hardwick
>_______________________________________________
>gimp-user-list mailing list
>List address:    gimp-user-list@gnome.org
>List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list

>List archives:   https://mail.gnome.org/archives/gimp-user-list
>


_______________________________________________
gimp-user-list mailing list
List address:    gimp-user-list@gnome.org
List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list
List archives:   https://mail.gnome.org/archives/gimp-user-list

Reply via email to