And the problem is identified at GMIC - GIMP devs removed a deprecated
procedure and not the GMIC QT plugin fails to load in GIMP 2.99.12 (though
I tried to down-rev my GIMP version back to 2.99.8 and the plugin still
failed to load despite my memory that it did work before I updated my
Kubuntu from 20.04 to 22.04). C'est la vie. Will have to wait until GMIC
(or someone) updates that GMIC Qt plugin. <sigh>


“Happiness is the meaning and the purpose of life, the whole aim and end of
human existence.”

― Aristotle

---------- Forwarded message ---------
From: Guy Stalnaker <>
Date: Fri, Oct 14, 2022 at 10:39 AM
Subject: GMIC and 2.99.12
To: GIMP-user-list <>

All, recently updated GIMP to 2.99.12 and the GMIC plugin no longer appears
on the Filter menu. I'm using the Flatpak for 2.99.12 (which was updated
when I updated my distribution from 20.04 to 22.04). GIMP works fine, it's
just getting GMIC to show up. I confirm that GMIC-QT is installed and runs
fine as a standalone app. But no matter what I do, the gmic_gimp_qt plugin
that gets installed in /usr/lib/gimp/2.0/plug-ins/gmic_gimp_qt is not
recognized by GIMP 2.99.12 on load. In fact, even with --verbose output
starting GIMP from a terminal there is no output of any kind that appears
to touch it -- no reading plugin, no error on attempting to read the
plugin. It's as if it's not there. I've copied the files from
/usr/lib/gimp/2.0/plug-ins to multiple locations (e.g.,
~/.config/GIMP/2.99/Plug-ins/) attempting to get GIMP to at least see it
and then hopefully toss an error of some kind, but nothing doing. I've
- gmic_ubuntu22.04_jammy_amd64.deb
- gmic_3.1.6_ubuntu22.04_jammy_amd64.deb
- GMIC 3.0 Flatpak

The .deb packages downloaded from GMIC. Nothing doing. GIMP 2.10.12 works
just fine and GMIC appears on the Filters menu. Just not GIMP 2.99.12. GMIC
worked with 2.99.8 (my previous version of GIMP).

Any help is appreciated.
gimp-user-list mailing list
List address:
List membership:
List archives:

Reply via email to