First off, thanks all for the insight and help, I finally
have my script running and saving my images perfectly.
However I'm having a bit of a problem running it from
Batch mode under redhat 6.2 Linux (Gimp 1.2.1)

I have already teied following Adrians tutorial but its either
wrong or outdated, or I just don't comprehend. I know batch
mode works because,
gimp -b '(gimp-quit 1 0)'
will load and then quit gimp just fine. So im my script i
changed the define and register to underscores in the name,
I made sure not to pass color arrays, and all text variables
are defined as string or font so that no need to escape quotes
on the command line.

I have attached my script, can anyone get this working in batch
mode? This is the command i tried
gimp -i -b '(script-fu-hire-buttons 1 "Test" 6
"-*-arial-bold-r-*-*-14-*-*-*-p-*-*-*" 14 255 255 255 255 255 255 0 0 0)'
'(gimp-quit 1 0)'

which I get:
batch command: experienced an execution error.

so i tried it in the Console and it makes the image funny, all layers
are black on black and half the size they should be but at least it
does run without errors. any suggestions or can anyone get this
working in batch mode?



Reply via email to