On 2002-01-09 at 2248.15 -0500, Forner, Sven typed this mail:
> Hi all,
> I try to write my first script to generate some thumbnails from my
> photos with Gimp in batch mode. For better debugging I test it first
> from the script-fu console. By correcting some other errors I
> discovered, that the script does not get the correct paramters from the
> command line.
> The call in the script-fu console: (script-fu-sven-scale 1 "014_12.jpg"
> "231" "154" "test_thumb.jpg")
> causes an error (the cause of the error is not the problem), which shows
> that the script receives only the the first and the second paramter
> correct
> Script-Fu Error while executing
>  (script_fu_sven_scale "014_12.jpg" 231 231 "014_12.jpg")
> ERROR: too few arguments (see errobj)
> When I try the same script in interactive mode:
> (script-fu-sven-scale 0 "014_12.jpg" "231" "154" "test_thumb.jpg")
> it gets the correct parameters as can be seen in the error console:
> Script-Fu Error while executing
>  (script_fu_sven_scale "/home/sforner/test/014_12.jpg" 231 154
> "/home/sforner/test/test_thumb.jpg")
> ERROR: too few arguments (see errobj)
> If I add missing argument to the gimp-display-new call the interactive
> script works fine, BUT not the noninteractive.
> I hope someone can give me an advice, what I'm doing wrong.
I had all kinds of trouble with this "interactive" and "noninteractive"
stuff when i was using gimp perl.  There is a big yellow box towards the
top of this tutorial which might help you (ignore the perl part)

Here is a tutorial about the gimp script-fu which also might be helpful:

good luck!

Gimp-user mailing list

Reply via email to