On Mon, Jun 03, 2002 at 08:40:15PM -0400, John Culleton wrote:
> I just reinstalled Gimp 1.2.3. I have xv on my system. How do I get Guash
> on my xtn menu? 

I don't know anything about Guash, but...
> Also, Xsane warns users not to run as root. Unfortunately that is the 
> only way I can get it to show up in Gimp. If I run as an ordinary user 
> I have to fire up Xsane separately. the acquire popup menu shows 
> screen shot and xsane dvice dialog but not xsane proper. The dvice dialog 
> can't find the device. The device, /dev/usbscanner is there
> with permissions of rwrwrw.

Have you tried making the xsane executable suid?  I don't know whether
that is the proper way to fix your problem or not.  The executable on
my system doesn't seem to be suid.

On my system (Linux 2.4.13-ac8), the USB scanner is /dev/usb/scanner*,
and only has 774 permissions.  I think that is sufficient because you
don't need to write data to the scanner device, only read from it
(mine anyway).


Ben Logan: ben at wblogan dot net
OpenPGP Key KeyID: A1ADD1F0

The advertisement is the most truthful part of a newspaper.
                -- Thomas Jefferson
Gimp-user mailing list

Reply via email to