Hello,

I'm trying to use script-fu-drop-shadow in another scheme script.
Here it is:
(let* ((image (car (gimp-image-new 256 256 RGB)))
        (bottom-layer  (car (gimp-layer-new image 256 256 RGB-IMAGE "fond" 100 
NORMAL-MODE)))
        )
   (gimp-image-add-layer image bottom-layer 0)
   (gimp-drawable-fill bottom-layer BG-IMAGE-FILL)

   (let* ((text-layer (gimp-text-fontname image bottom-layer -1 0 "text" 0 TRUE 52 
PIXELS "-adobe-courier-bold-r-normal-*-*-140-*-*-m-*-iso8859-9")))
     (script-fu-drop-shadow 1 image text-layer "8" "8" "15" '(0 0 0) 
"80" TRUE)
     (gimp-floating-sel-anchor text-layer)
     ))

But gimp does not accept it, and the only error message I get
is a mysterious :
        ERROR: wta(1st) to max (errobj 8)

(print errobj) gives me the following:

        "8"
        ()

Can anybody help me, please ?
BTW, do you know a way to get real error messages ?

Thanks in advance,

-- 
Maxence Guesdon
_______________________________________________
Gimp-user mailing list
[EMAIL PROTECTED]
http://lists.xcf.berkeley.edu/mailman/listinfo/gimp-user

Reply via email to