Please Ignore that last attachment....I added the wrong one. I was testing
something else at that point.  This one illustrates what I was trying to do.


-- Forwarded message from [EMAIL PROTECTED] --
On Thu, 19 Dec 2002 04:32:07 -0000 (GMT), <pcg( Marc)@goof(A.).(Lehmann )com>
> On Thu, Dec 19, 2002 at 07:35:36PM -0000, [EMAIL PROTECTED] wrote:
> > image resizing from the command line.  I know that many of you out there
> are
> > going to point out that ImageMagick will do what I am looking for. I have
> > already gone down that path and the image quality of the scaled images is
> not up
> Then you probably have done sth. wrong, as ImageMagick's algorithms are
> way superior (and way slower ;) to the mere cubic interpolation gimp uses.
> Are you sure you tried sth. like:
>    convert sourcefile -filter mitchell -geometry <newgeometry> destfile

ok,  I tried this....and I got an image that was not up to par with what can be
done with Adobe's Image ready doing a similiar process.  However, with Gimp, I
can produce an image that is better and smaller than what Image Ready and
ImageMagick can do.    The mitchell filter was better than the cubic filter by
far...but they were still pixelated when you started to look at the images
closely.  I personally think the images are good enough for the web....however,
the client that I am working for is accustom to having an image of a very high

> also, other filters than the mitchell filter (which is usually best) are
> also worth a try, "cubic" for example should rather closely match gimp's
> quality.

> Well, I am no scirpt-fu expert, but I get a lot of mail that tells me that
> scirpt-fu simply doesn't work noninteractively, or at leats not correctly,
> or returns too earfly etc.. etc..

Ok, if script-fu is not meant to be run from the command line without
interaction....then why the batch mode option?

from the gimp man pages....
 -b, --batch <commands>
             Execute the set of <commands> non-interactively. The
             set  of  <commands>  is  typically  in the form of a
             script that can be  executed  by  one  of  the  Gimp
             scripting extensions.

Based on the documentation I have seen, I should be able to call a script-fu
function and everything should work.  That is not the case.

Attached is a cut down version of the script that I am attempting to call.   I
am calling this script from the command line as follows......

 gimp -b '(script-fu-test-script 1 "200" "200"

When this is run...I get back
batch command: executed successfully.

However, there is no outputted image to be found.   If I change the 1 to 0 to
run interactivly, it pops up the prompt for me to enter in the values needed for
the script and runs successfully.  Is there any way of outputting what has been
passed into a script?

Thoughts?  Comments?

Matt Patterson

Attachment: test-script.scm
Description: Binary data

Gimp-user mailing list

Reply via email to