I have spent about 4 days searching archives for the answer to waht I suspect is a silly question.

In short, I couldn't use gimp to print (reasonably) to my Photosmart 7150, and gimp wasn't being nice (like wasn't saving my printer setups for me, so if I spent an hour setting the gamma, it was all gone the next page I wanted to print), so i figured, well, first step is get the most up-to-date version of anything... so I downloaded the 1.3.11 source, and started the ./configure dance. Didn't get far...

1. it seems that gimp and gimp-print each want each other to exist first-- this seems like a "race condition". Do I reaaly have to compile gimp without printing, compile gimp-print,a nd then recompilee gimp?

2. GIMP wants pango with freetype 2.

I have rpmed in freetype2

[root@pasteur pango-1.2.1]# rpm -qa | grep freetype

but when I compile pango, pangoft2.* doesn't happen. what am I missing?

all I did was the ./configure make make install dance with pango, and I couldn't find anything in the doc to tell me how to tell it about freetype2. It does identify a freetype >=2.0 in the config. I tried ./configure --with-freetype2 but that didn't help.

3. everything complains about xft and fontconfig being missing. tried rpming those in and Xft went fine but fontconfig barfed wanting a newer glibc than I had. Are these necessary?

I have RH 7.X, and XFree86 4.2.0

recompiled and installed GTK2.2.1, and all of the "upstream stuff" for that wihtout any explosions.

thanks for any help about what I am missing.


No one can deny that since the Origin was published man has given a
good exhibition of his lowly nature. Darwin's book can explain man's
bestial propensities, but it is scarcely responsible for them.
--Homer W Smith

William H. Fissell MD
University of Michigan Hospitals

Gimp-user mailing list

Reply via email to