OK.  I am having serious trouble when trying to install gimp-1.2.5.tar.gz

This is what I get at the end of the 'make' procedure.
creating script-fu
make[4]: Leaving directory `/home/david/gimp-1.2.5/plug-ins/script-fu'
make[3]: Leaving directory `/home/david/gimp-1.2.5/plug-ins/script-fu'
Making all in perl
make[3]: Entering directory `/home/david/gimp-1.2.5/plug-ins/perl'
make[3]: *** No rule to make target `all'.  Stop.
make[3]: Leaving directory `/home/david/gimp-1.2.5/plug-ins/perl'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/david/gimp-1.2.5/plug-ins'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/david/gimp-1.2.5'
make: *** [all-recursive-am] Error 2
What does 'all recursive error' mean?  Apart form something being wrong.

In addition I cannot get a requirement to install.  The requirement is perl-pdl.  I've downloaded it. this is the file perl-PDL-2.4.0-2mdk.i586.rpm.  But when installing it complains about a series of perl files.

error: failed dependencies:
        perl(ExtUtils::MakeMaker)   is needed by perl-PDL-2.4.0-2mdk
        perl(File::Basename)   is needed by perl-PDL-2.4.0-2mdk
        perl(Getopt::Std)   is needed by perl-PDL-2.4.0-2mdk
        perl(strict)   is needed by perl-PDL-2.4.0-2mdk
        perl(vars)   is needed by perl-PDL-2.4.0-2mdk
I've tried using cpan to download the files. But perl-pdl still will not install..a recursive failed dependencies loop...I fear.

I must admit I'm getting a little sick of running into problems just trying to update my version of gimp.  So if anyone has any idea what is happening please let us know.


Reply via email to