>===== Original Message From [EMAIL PROTECTED] ( Marc) (A.) (Lehmann ) =====
>On Wed, Jul 30, 2003 at 03:44:11PM -0500, Michael Dingwall 
<[EMAIL PROTECTED]> wrote:
>> Subroutine Gimp::gimp_file_load redefined at /(path to Gimp.pm/Gimp.pm on 
line
>> 541
>
>This is probably a bug in gimp-perl with the compatibility syntax. Could
>you try to use object-oriented syntax, i.e.
>
>   Gimp->file_image_load (...
>   $img->active_drawable;
>   $img->file_save (...);

Ok, all of this worked.  However, when it comes to doing that with the 
plug_in_edge function I get an error telling me about a procedural database 
exection falure.

testloop.pl: plug_in_edge: procedural database execution failed at 
./testloop.pl line 52

This time I'm gonna include the testloop.pl script that I wrote.  Maybe with 
that it will help.

>
>and tell me wether that works? thx.



>
>> however these warnings keep showing up.  I've tried the trace mechanism and 
it
>> crashes after the gimp_image_load statement.
>
>Woaw. How does it crash (I can't reproduce that here)?

I guess that it reall doesn't crash, it hangs.  Whenever using TRACE_ALL it 
hangs after the get_file_load command.  With TRACE_CALL it hangs in the same 
place that I get the pdb error above.

>
>--
>      -----==-                                             |
>      ----==-- _                                           |
>      ---==---(_)__  __ ____  __       Marc Lehmann      +--
>      --==---/ / _ \/ // /\ \/ /       [EMAIL PROTECTED]      |e|
>      -=====/_/_//_/\_,_/ /_/\_\       XX11-RIPE         --+
>    The choice of a GNU generation                       |
>                                                         |



Thx for the help.

Michael

Attachment: testloop.pl
Description: Binary data

_______________________________________________
Gimp-user mailing list
[EMAIL PROTECTED]
http://lists.xcf.berkeley.edu/mailman/listinfo/gimp-user

Reply via email to