On Sat, Nov 08, 2003 at 01:56:17PM -0800, Daniel Rogers wrote:
> On Saturday, November 8, 2003, at 07:01  AM, Sven Neumann wrote:
> >Hi,
> >
> >Jacob Meuser <[EMAIL PROTECTED]> writes:
> >
> >>I'm trying to build gimp-1.3.22 within OpenBSD's ports framework.
> >>It does a "fake install" and then builds a package from the "fake
> >>install root".  I'm having a problem with libtool relinking
> >>libgimpmodule, and looking for libgimpbase in /usr/local instead
> >>of the "fake install root".
> >
> >AFAIK libtool does always relink the libraries at installation. I
> >don't think there's a way around this but I might be wrong.
> I don't think his problem is with relinking, per say.  The problem is 
> that he is "faking" and install by changing (I believe) the 
> INSTALL_ROOT make variable.  This is done to compare the installed 
> files with the in place versions.  The problem being encountered, I 
> think, is that libtool is looking for libgimpbase in /usr/local instead 
> of the fake install location (something like 
> /var/tmp/ports/<package_name>/install/usr/local).

Yes, this is what's happening.

> I still have no idea why this problem would show up, as I thought 
> libtool knew how to handle fake installs.

I thought so too (gimp-1.2.x, as well as a myriad of other apps, don't
have this problem), but sometimes this happens with libtool.

I'll dig a little deeper into libtool and look at some other apps
built with libtool to see if I can find why it's happening and
how to change it.

Gimp-user mailing list

Reply via email to