On Fri, 2004-01-02 at 02:02, Gene Heskett wrote:
> Hi; this is rather offtopic, 

I'll say!

> but maybe somebody's been there and done that.
> Trying to get gkrellm to watch the system when the kernel is a
> 2.6.x requires a new gkrellm-2.whatever
> That in turn needs gtk+-2.2.x
> That needs a new pango, atk and glib, all suitable 2.2.x versions.
> I've setup an env var $PKG_CONFIG_PATH thats correct, and I reran
> ldconfig everytime I updated by the time honored method of doing
> an "rpm -e --nodeps oldpackage" and then installing the new one
> from the tarball.
> Everything went nominally till I got to gtk+-2.2.4, after having
> installed the 2.2.3 versions of pango, atk, and glib.  I've been about
> an hour now on search and destroy of older glib-2.2.1 stuff which
> is causeing this gtk+-2.2.4 ./configure exit:
> checking for pkg-config... (cached) /root/kde3.1.1/bin/pkg-config
> checking for GLIB - version >= 2.1.4...
> *** 'pkg-config --modversion glib-2.0' returned 2.2.3, but GLIB (2.2.1)
> *** was found! If pkg-config was correct, then it is best
> *** to remove the old version of GLib. You may also be able to fix the error
> *** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
> *** /etc/ld.so.conf. Make sure you have run ldconfig if that is
> *** required on your system.
> *** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
> *** to point to the correct configuration files
> no
> configure: error:
> *** GLIB 2.1.4 or better is required. The latest version of
> *** GLIB is always available from ftp://ftp.gtk.org/.
> I think that (cached) is the killer.  Humm, thats one dir I haven't
> checked for an older glib-2.0.pc.  Ok, killed the entries in
> /root/kde3.1.1/lib/pkgconfig, didn't help.  And glib-2.2.1 was removed
> with the rpm -e --nodeps option.  The gimp runs, but gftp won't, so I'm
> messed something up.  I've reinstalled glib-2.2.3 a dozen times, and
> now I can't even rebuild pango, getting the same ./configure error.
> Where is the right place to find help for this?
> Should I rebuild and re-install everthing with --prefix=/usr?

Old problem, solved a number of times on different mailing lists. Google
is probably your friend here.

You need to set LD_LIBRARY_PATH to point to the new glib libraries as

Gimp-user mailing list

Reply via email to