On Mon, Jan 12, 2004 at 11:09:55AM +0100, Przemyslaw Gawronski wrote:
> Dnia Mon, Jan 12, 2004 at 10:27:45AM +0100, Sven Neumann napisa?:
> 
> > It would certainly help if you could describe more precisely how the
> > scripts don't work.
> 
> Yes, sorry, about leaving that out.
> 
> Here it is:
> 
> [EMAIL PROTECTED] gawron]$ gimp-1.3 &
> [1] 4311
> [EMAIL PROTECTED] gawron]$ This is a development version of The GIMP.
> Debug messages may appear here.
> 
> gimp_composite: use=yes, verbose=no +mmx +sse +sse2 -3dnow -altivec -vis
> Traceback (most recent call last):
>   File "/home/gawron/lib/gimp/1.3/python/gimpfu.py", line 427, in _run
>     extra_params = _interact(func_name)
>   File "/home/gawron/lib/gimp/1.3/python/gimpfu.py", line 239, in _interact
>     import gimpui
>   File "/home/gawron/lib/gimp/1.3/python/gimpui.py", line 15, in ?
>     pygtk.require('2.0')
>   File "/usr/lib/python2.2/site-packages/pygtk.py", line 45, in require
>     assert not sys.modules.has_key('gtk'), \
> AssertionError: pygtk.require() must be called before importing gtk
> 
> I've tryied to run from the main menu:
> 
> Extras->Python-Fu->Misc->Sphere
> 
> All other python scripts endup the same way.

Your version of pygtk is too old, you should use at least 1.99.15, or even
better 2.0.0.

I've updated the configure script to enforce this.

-Yosh
_______________________________________________
Gimp-user mailing list
[EMAIL PROTECTED]
http://lists.xcf.berkeley.edu/mailman/listinfo/gimp-user

Reply via email to