On Monday 12 January 2004 07:03, Przemyslaw Gawronski wrote:
> Hi, I've downloaded gimp2.0.pre, compiled (with --enable-python),
> but the scripcts included don't work. Is this known, or there is
> something wrong with my installation ?
>
> Thanks for some information.
>
> Przemek

Hi there,

There is an issue with Python when changing from gtk 1.x to gtk 2.x  - 
and that happens when you change from GIMP 1.2 to GIMP 2.x.

It is IMO, quite shamefull for the PyGTK guys, but is "work 
aroundable".

The is a file in the Python packages which says which version of GTK 
porgrans that use PyGTK and the GIMP  Python is such  a program) will 
use.

It is called "pygtk.pth".
Locate this file in your python directories, and change its content 
from:
gtk-1.2
to:
gtk-2.0

-
When you want to run gimp 1.2.5 python scripts, you have  to revert 
this.
.

The whole issue exists because the PyGTK guys  (ok, not all of them, 
it was an individual decision) did not want to create a "gtk2" 
module, and kept the name of the gtk2 module as "gtk", thus breaking 
backwards compatibility.


Regards,
        JS
        -><-


_______________________________________________
Gimp-user mailing list
[EMAIL PROTECTED]
http://lists.xcf.berkeley.edu/mailman/listinfo/gimp-user

Reply via email to