Brad Kligerman <[EMAIL PROTECTED]> writes:
I've been trying to upgrade from GIMP 1.2.3 that was installed with
RH9 to GIMP 1.3.23.
It won't configure, and I get the following...

[EMAIL PROTECTED] gimp-1.3.23]# ./configure
checking for pkg-config... (cached) /usr/bin/pkg-config
checking for GTK+ - version >= 2.2.2...
*** 'pkg-config --modversion gtk+-2.0' returned 2.2.4, but GTK+ (2.2.1)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GTK+. You may also be able to fix the
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files no
configure: error: Test for GTK+ failed. See the file 'INSTALL' for help.

I installed GTK 2.2.4 and followed all the other installation
instructions.  When I check the version of GTK+ with Synaptic, it
shows _GTK2 - version 2.2.1-4_ and not 2.2.4. Is this  where the
problem is coming from. Any ideas??

Yes, that's where your problem is coming from. While pkg-config
locates the new version, your linker takes the library from /usr/lib.
The error message suggests the possible solutions. You can modify the
linker behaviour by adjusting your LD_LIBRARY_PATH enviroment variable
or by editing /etc/
I already had edited _/etc/ and ran _ldconfig_ as suggested in the message. It also suggests that I remove version GTK+ 2.2.1, which I never installed, and to the best of my knowlege, is not on my system.
Synaptics says that I have _GTK2 - version 2.2.1-4_ and not _GTK+2.2.4_.
Could this be the problem??

Reply via email to