Sorry being naughty :)) But the only thing I had to install by hand was
xfree 4.2.1 and apparently here a different library has been used.
Appaerently the new fontconfig is installed in /usr/x11r6/lib and the
one installed bij xfree in /usr/lib. Can I fix this with symbolic link ?

Greetz,
Johan


spin:/home/johan# ldconfig -p | grep fontconfig
        libfontconfig.so.1 (libc6) => /usr/X11R6/lib/libfontconfig.so.1
        libfontconfig.so.1 (libc6) => /usr/lib/libfontconfig.so.1
        libfontconfig.so (libc6) => /usr/X11R6/lib/libfontconfig.so
        libfontconfig.so (libc6) => /usr/lib/libfontconfig.so

spin:/home/johan# ldconfig -p | grep gimp
        libgimpwidgets-2.0.so.0 (libc6) =>
/usr/lib/libgimpwidgets-2.0.so.0
        libgimpwidgets-2.0.so (libc6) => /usr/lib/libgimpwidgets-2.0.so
        libgimpui-2.0.so.0 (libc6) => /usr/lib/libgimpui-2.0.so.0
        libgimpui-2.0.so (libc6) => /usr/lib/libgimpui-2.0.so
        libgimpui-1.2.so.0 (libc6) => /usr/lib/libgimpui-1.2.so.0
        libgimpthumb-2.0.so.0 (libc6) => /usr/lib/libgimpthumb-2.0.so.0
        libgimpthumb-2.0.so (libc6) => /usr/lib/libgimpthumb-2.0.so
        libgimpprint.so.1 (libc6) => /usr/lib/libgimpprint.so.1
        libgimpprint.so (libc6) => /usr/lib/libgimpprint.so
        libgimpmodule-2.0.so.0 (libc6) =>
/usr/lib/libgimpmodule-2.0.so.0
        libgimpmodule-2.0.so (libc6) => /usr/lib/libgimpmodule-2.0.so
        libgimpmath-2.0.so.0 (libc6) => /usr/lib/libgimpmath-2.0.so.0
        libgimpmath-2.0.so (libc6) => /usr/lib/libgimpmath-2.0.so
        libgimpcolor-2.0.so.0 (libc6) => /usr/lib/libgimpcolor-2.0.so.0
        libgimpcolor-2.0.so (libc6) => /usr/lib/libgimpcolor-2.0.so
        libgimpbase-2.0.so.0 (libc6) => /usr/lib/libgimpbase-2.0.so.0
        libgimpbase-2.0.so (libc6) => /usr/lib/libgimpbase-2.0.so
        libgimp-2.0.so.0 (libc6) => /usr/lib/libgimp-2.0.so.0
        libgimp-2.0.so (libc6) => /usr/lib/libgimp-2.0.so
        libgimp-1.2.so.0 (libc6) => /usr/lib/libgimp-1.2.so.0

On Mon, 2004-04-12 at 00:59, Manish Singh wrote:
> On Sun, Apr 11, 2004 at 08:18:43PM +0200, johan wrote:
> > Hi,
> > 
> > I have something weard : i just installed gimp 2.0, once tried from
> > .deb, once from source. When I open gimp i receive the following message
> > : 
> > gimp message : fontconfig version too old, The GIMP requires fontconfig
> > version 2.2.0 or later.
> > Installed fontconfig version is 1.0.2.
> > 
> > Somehow you or your software packager managed
> > to install The GIMP with an older fontconfig version.
> > 
> > Please upgrade to fontconfig version 2.2.0 or later.
> > 
> > This is really strange, since i have version 2.2.2 of fontconfig
> > dpkg -l fontconfig
> > ii  fontconfig     2.2.2-2        generic font configuration library
> > 
> > Anybody has an idea ? (I have Xfree4.2.1)
> 
> You have more than one fontconfig library on your system. The debian one
> is in /usr/lib, you likely have another one in /usr/X11R6/lib or
> /usr/local/lib. You can run ldd on the gimp binary to find the path of
> the library it's using.
> 
> This message has been improved for 2.0.1 to clarify this situation,
> because it seems quite some number of naughty people don't keep track of what
> they installed on their system by hand..
> 
> 
> -Yosh

_______________________________________________
Gimp-user mailing list
[EMAIL PROTECTED]
http://lists.xcf.berkeley.edu/mailman/listinfo/gimp-user

Reply via email to