Owen wrote:
On Mon, 03 May 2004 16:52:52 -0700
Barton Bosch <[EMAIL PROTECTED]> wrote:

checking for aa_printf in -laa... no
configure: WARNING: *** AA plug-in will not be built (AA library not found) ***
checking for libgtkhtml-2.0 >= 2.0.0... Package libgtkhtml-2.0 was not found in
the pkg-config search path.
Perhaps you should add the directory containing `libgtkhtml-2.0.pc'
to the PKG_CONFIG_PATH environment variable
configure: WARNING: *** Help browser plug-in will not be built (GtkHtml2 not found) ***
checking for cmsCreate_sRGBProfile in -llcms... no
configure: WARNING: *** color proof module will not be built (lcms not found or
unuseable) ***

I wouldn't worry too much about all those.

I figured as much, but with such a long compile I thought I would try to get all of the wrinkles ironed out before I tried making gimp2.0.1.

gtkthml2 was installed on my system, it was just lacking the
headers from the devel package.  I did run a check (actually
double checked with the filter on my local repository) and i
could have sworn gtkhtml was not installed...  So the help
browser situation was resolved with a simple rpm -Uvh. I thought
that someone on the list might know what lcms and laa were off
the top of their heads but in the meantime I did eventually
manage to track these packages down.

The ascii art plug in is not really essential, more of a toy in my view.

A red hat 9 (shrike) rpm for laa can be found in on freshrpms (http://shrike.freshrpms.net/rpm.html?id=1184).

libgtkhtml is for the help, but there's not much in the way of help at the moment, so you don't need it. If you want the help, you need to get it from CVS and build it from there.

gtkhtml and gtkhtml2 are standard red hat rpms (I just looked through them somehow <g>).

lcms, you sure you haven't got it? Anyway, it too is not really necessary for Gimp operation, but is useful for color proofing type work.

lcms is not a standard red hat package as far as I can tell, and I wasn't able to find an rpm at all. The compile was more or less painless though. The source can be found at: http://www.littlecms.com/downloads.htm.

Combined with the rpms for updating rh9 for compiling gimp2.0.x
from source (found at http://xach.com/gimp/rpms/), the
gimp-print rpms for rh9 (at:
the gimp-gap source (which requires wavplay for audio playback
to function -- this was a little tough to find as search engines
turned up many random listings for obsolete versions, though I
got the source for 1.4 from:
http://adnc.linux.tucows.com/preview/47649.html), and a bunch of
the optional packages (libexif, libwmf, libsrvg, the
gimp-documentation, etc.); I did get the gimp compiled and
configured. It even looks operational now, though I haven't had
time to test it much yet <g>. From what I have done the UI seems better, maybe a little smoother. GIMP also feels a little faster though that could be totally subjective. All in all, so far so good -- a bigup to all the developers and contributors for this fine free software.

I do have another question, re:  the Perl plugin though.  When
trying to compile it it says that it can't find gimp when it
tries to run the test program:

checking for GIMP - version >= 2.0.0... no
*** Could not run GIMP test program, checking why...
*** The test program compiled, but did not run. This usually means
*** that the run-time linker is not finding GIMP or finding the
*** version of GIMP. If it is not finding GIMP, you'll need to
set your
*** LD_LIBRARY_PATH environment variable, or edit
/etc/ld.so.conf to point
*** to the installed location  Also, make sure you have run
ldconfig if that
*** is required on your system
*** If you have an old version installed, it is best to remove
it, although
*** you may also be able to get things to work by modifying
configure: error: ** unable to find gimp, make sure it's in your
path (version 1.3.15+ required!)

I tried putting the location of the gimp binary into ld.so.conf and the LD_LIBRARY_PATH variable, but no joy. What is the story here? Was I supposed to put the location of a library in the path variable? Something else entirely? Anyone have any solutions?

There was also a small problem with the gimp swap file location.
  When I configured gimp on the first run I tried moving the
swap file to /tmp as suggested but there was a problem (probably
permissions) and gimp couldn't open it.  In the
Preferences->Folders menu there is a dialog box for changing the
location of the swap file.  I changed it to various locations,
but each time I restarted the gimp it reverted to the location
set during the original configuration.  Changing it through the
preferences menu wasn't possible.  Eventually it was fixed by
editing .gimp/gimprc the old fashioned way.



Gimp-user mailing list

Reply via email to