This is mostly a binch of tips (and a disclaimer - I haven't read
the rest of the thread yet, so these may be duplicates)...

> I tried to build 2.1.4 and kind of succeeded, but it couldn't open files. I
> could barely start it, actually. THere was dozens of error messages during
> startup from the local dir about "libgimpwidgets-2.0-104" couldn't be located.

You may have tried to install the GIMP 2.1 into the same
directory as the old GIMP, and this does not work. It's
documented in the "README" file, which you read, of course. ;)

I don't know how those errors manifest themselves, and I would
have expected something more subtle than this, but however...

> And even with a full install that's right: It's not on disk. Nor did the
> installation routine relink "gimp" to the new binary.

This is normal - since 2.1.x is a development series, we assume
that you will be doing day-to-day work with 2.0.x, and we leave
the gimp linking to gimp-2.0.

> I finally gave up and
> deleted the whole thing - it could only open xfc files, no "plugins" worked,
> and the filepicker has become an unusable mess... What on earth happened to the
> it? I can't use it anymore :(((

For the files, this is because xcf is loaded and saved in the
core, while every other format goes through a plug-in. Since
libgimp is not found, the plug-ins don't load, and are thus not

You can use the old 2.0 plug-ins by doing something like "ln -s
/usr/lib/gimp/2.0/plug-ins ~/.gimp-2.1/plug-ins ", but then you
will not have all the bug-fixes and previews which have gone into
the 2.1 series.

> There is nowhere to paste in the URLs (filepath/name).

Ctrl-F (Find) brings up a filename entry dialog box where you can
paste URLs or file paths.

> I used to browse my
> galleries in mozilla, and then paste the url/filepath+name into the gimp
> filepicker.

If this is your preferred way to browse files, then you might
consider dragging and dropping the URLs from the Location bar
into the toolbox of the GIMP. This even works for remote images
in web-pages, and drag & drop also works with multiple files, you
can drop files to the layers dock to have them added as layers to
your image, and D&D also works for lots of other things (colours,
patterns, layer previews, etc).

> I tested it under Gnome too: There I can see icons at least. But I can't use
> Gnome for other reasons. I guess it all means that the Gimp has changed from a
> Gtk app to a Gnome app.

No, this isn't the case. Perhaps you are missing the icon themes,
which are an optional but reccommended component for the GIMP?


        David Neary,
        Lyon, France
CV: http://dneary.free.fr/CV/
Gimp-user mailing list

Reply via email to