I just installed a boatload of updated (built for SuSE) rpms from 
www.usr-local-bin.org. 

Here's what I installed:
atk-1.8.0-100.SuSE.ulb.1.i586.rpm
atk-devel-1.8.0-100.SuSE.ulb.1.i586.rpm
glib2-2.4.6-100.SuSE.ulb.1.i586.rpm
glib2-devel-2.4.6-100.SuSE.ulb.1.i586.rpm
gtk2-2.4.10-100.SuSE.ulb.1.i586.rpm
gtk2-devel-2.4.10-100.SuSE.ulb.1.i586.rpm
gtk2-engines-2.2.0-400.SuSE.ulb.2.i586.rpm
libcroco-0.6.0-100.SuSE.ulb.1.i586.rpm
libcroco-devel-0.6.0-100.SuSE.ulb.1.i586.rpm
librsvg-2.7.2-100.SuSE.ulb.1.i586.rpm
librsvg-devel-2.7.2-100.SuSE.ulb.1.i586.rpm
pango-1.6.0-100.SuSE.ulb.1.i586.rpm
pango-devel-1.6.0-100.SuSE.ulb.1.i586.rpm

And here's where 'make' is pooping out:
 gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I/opt/gnome/include/gtk-2.0 
-I/opt/gnome/lib/gtk-2.0/include -I/opt/gnome/include/atk-1.0 
-I/opt/gnome/include/pango-1.0 -I/usr/X11R6/include -I/usr/include/freetype2 
-I/usr/include/freetype2/config -I/opt/gnome/include/glib-2.0 
-I/opt/gnome/lib/glib-2.0/include -I/usr/local/include 
-DG_LOG_DOMAIN=\"LibGimpWidgets\" -DGIMP_DISABLE_DEPRECATED -DG_DISABLE_DEPRECATED 
-DGDK_PIXBUF_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DGDK_MULTIHEAD_SAFE 
-DGTK_MULTIHEAD_SAFE -g -O2 -Wall -MT gimpstock.lo -MD -MP -MF .deps/gimpstock.Tpo -c 
gimpstock.c  -fPIC -DPIC -o .libs/gimpstock.o
gimpstock.c:303: error: `stock_anchor_16' undeclared here (not in a function)
gimpstock.c:303: error: initializer element is not constant
gimpstock.c:303: error: (near initialization for 
`gimp_stock_button_pixbufs[0].inline_data')
gimpstock.c:303: error: initializer element is not constant
gimpstock.c:303: error: (near initialization for `gimp_stock_button_pixbufs[0]')
gimpstock.c:304: error: `stock_duplicate_16' undeclared here (not in a function)
gimpstock.c:304: error: initializer element is not constant
gimpstock.c:304: error: (near initialization for 
`gimp_stock_button_pixbufs[1].inline_data')
gimpstock.c:304: error: initializer element is not constant
gimpstock.c:304: error: (near initialization for `gimp_stock_button_pixbufs[1]')
gimpstock.c:305: error: `stock_edit_16' undeclared here (not in a function)
gimpstock.c:305: error: initializer element is not constant
...

Any ideas?

Thanks for reading,
Eric Pierce
_______________________________________________
Gimp-user mailing list
[EMAIL PROTECTED]
http://lists.xcf.berkeley.edu/mailman/listinfo/gimp-user

Reply via email to