> Subject: Re: [Gimp-user] Cannot compile gimp 2.0.x on RHAT9 --> GTK+2 not  
> found
> Michael Schumacher wrote:
> Nah, just a bit lack of knowledge on your side ;)

Thanks for clearing it up.  I'm not too experienced with GNOME utils. 
And I see that the .pc files are quite useful.  I was used to the
*old* way where you specified non-standard library paths as parameters
to the configure script.

Anyway, for the record here's what I did:

1.  edit /etc/ld.conf - added /usr/local/lib  - This is where GTK+2
was installed (by default).
2.  set the env variables.  The GTK+ 2 package config file gtk+-2.0.pc
gets installed (by default) to /usr/local/lib/pkgconfig.  So for this
configure script to find it set:

  PKG_CONFIG_PATH=/usr/local/lib/pkgconfig/; export PKG_CONFIG_PATH

Similary, the GTK+ 2 libraries are installed in /usr/local/lib, so set:

  LD_LIBRARY_PATH=/usr/local/lib; export LD_LIBRARY_PATH

FYI - I tried editing /etc/ld.conf (adding /usr/local/lib) and then
running /sbin/ldconfig and this didn't work.

I then reran ./configure for gimp 2.0.6 and it worked.

Gimp-user mailing list

Reply via email to