On Thu, Jan 13, 2005 at 06:45:36PM +0100, Ron Eggler wrote:
> >On Wed, Jan 12, 2005 at 06:32:43AM +0100, Ron Eggler wrote:
> >> i try to install gimp2.
> >> had to update glib(2.6.0), pkconfig (0.14.0) but still get this error:
> >> [c&p]
> >> checking for pkg-config... /usr/local/bin/pkg-config checking for GLIB 
> >> - version >= 2.4.5... no
> >>  
> >i am just guessing, it has been a long time since i have had pkg-config
> problems; perhaps you are searching only in >/usr/local and not in /usr/.
> >
> >the first place i would check that your linking system searches both
> locations.
> >
> Erm how do I check that?
i was going to suggest that you add the path to /etc/ld.so.conf but i
just checked mine and the path to /usr/lib (which is where my glib
lives) is not there.

i read the pkg-config manpage:
[EMAIL PROTECTED]:~$ pkg-config --modversion glib-2.0

then i confirmed where i thought it should be:
[EMAIL PROTECTED]:~$ ls /usr/lib/pkgconfig/glib*
/usr/lib/pkgconfig/glib-2.0.pc  /usr/lib/pkgconfig/glib.pc

then i confirmed where it is not:
[EMAIL PROTECTED]:~$ ls /usr/local/lib/glib*
ls: /usr/local/lib/glib*: No such file or directory

i dont know the reason it works for me and not for you.  perhaps at this
point it is good to ask what your distribution is and what version of it
you are running.

have you built other things?  you might need to install the -dev version
of glib also.  actually, it would be very good to know if you have
successfully built other software.


Gimp-user mailing list

Reply via email to