--pdb-compat-mode on : made no difference

--pdb-compat-mode warn : produced the following error messages on std out (between #############)


############################################################ GIMP: WARNING: Plug-In "script-fu" (/usr/lib/gimp/2.0/plug-ins/script-fu) called deprecated procedure 'gimp_palette_set_background'. It should call 'gimp_context_set_background' instead!

GIMP: WARNING: Plug-In "script-fu"
(/usr/lib/gimp/2.0/plug-ins/script-fu)
called deprecated procedure 'gimp_palette_get_foreground'.
It should call 'gimp_context_get_foreground' instead!

GIMP: WARNING: Plug-In "script-fu"
(/usr/lib/gimp/2.0/plug-ins/script-fu)
called deprecated procedure 'gimp_palette_get_background'.
It should call 'gimp_context_get_background' instead!

GIMP: WARNING: Plug-In "script-fu"
(/usr/lib/gimp/2.0/plug-ins/script-fu)
called deprecated procedure 'gimp_palette_set_foreground'.
It should call 'gimp_context_set_foreground' instead!

GIMP: WARNING: Plug-In "script-fu"
(/usr/lib/gimp/2.0/plug-ins/script-fu)
called deprecated procedure 'gimp_palette_set_background'.
It should call 'gimp_context_set_background' instead!

Button: Error while executing
(script-fu-aqua-pill-button "The GIMP" 16 "Arial Black" '(0 0 0) '(121 161 248) '(229 238 255) 1 1 1 1 1 TRUE TRUE TRUE TRUE)
ERROR: Procedural database execution failed:
(gimp_edit_fill 7 0)
#######################################


Using non-deprecated FOREGROUND-FILL constant or the number 1 rather than FG-IMAGE-FILL causes the above error message to be displayed (so I don't think it is related to the constant)

Using the constant the PDB seems to recommend GIMP-FOREGROUND-FILL results in an "unbound variable" error being displayed. Why does FOREGROUND-FILL work and GIMP-FOREGROUND-FILL fail? Is that a mistake in the PDB or should I just know to knock GIMP- off the front of the name?

Any ideas?

Many Thanks.

Graham

Sven Neumann wrote:
Hi,

Graham Smith <[EMAIL PROTECTED]> writes:


I've got a bit of a problem with a script that I make fairly
extensive use of to create buttons for websites. It started out life
as a GIMP-1.1 script and I upgraded it to work with GIMP-2.0 but
have recently upgraded again to GIMP-2.2. Unfortunately this has
broken the script (right when I need it of curse) and I can't figure
out what is wrong.


You are using deprecated constant names (FG-IMAGE-FILL should be
FOREGROUND-FILL). I am however somewhat surprised since the old names
are still supposed to work. Try if starting gimp with the
'--pdb-compat-mode on' or '--pdb-compat-mode warn' command-line
options makes a difference.


Sven
_______________________________________________
Gimp-user mailing list
Gimp-user@lists.xcf.berkeley.edu
http://lists.xcf.berkeley.edu/mailman/listinfo/gimp-user

Reply via email to