Hi folks,

I'm sorry to barge in here, but I don't really know where else to turn.

I'm on RH9.  I finally decided to upgrade the GIMP from 1.3.x to 2.2.6
(more about that in a minute).

The problem I have right now is that it will not open or write tiff's.
 Now I suspect it is b/c of how I installed it.

I installed into a custom location (with the --prefix option when I
ran configure).  During the upgrade, the first thing I discovered was
that I needed to upgrade GTK+ and GLib.  A while ago I tried upgrading
those packages and realized that was a terrible idea.  So I found
http://www.cryptnet.net/fdp/gtk/local_install.html which told me how
to install them in a different directory and use them.

So that's what I did, I installed GTK+ 2.6.7 and glib 2.6.4 into my
$HOME/usr directory.  I ran into a problem with them complaining about
some things and I ended up installing the following into the custom
directory as well:
atk 1.9.0
fontconfig 2.2.96
freetype 2.1.9
glib 2.6.4
gtk+ 2.6.7
pango 1.8.1
pkgconfig 0.17.1
libtiff 3.7.2

During the install I had to set a number of environmental vars:

LIBTIFF=/home/strycat/usr/lib -ltiff

Now once I did all of that that I compiled the gimp.  It complained
about not having gimp-print so I used the --disable-print option when
I ran configure.  It complied and installed fin into $HOME/usr

However it doesn't seem to know anything about tiff files now.  I'm
pretty sure I've done something wrong while compiling it.  Can anyone
help?  I've been struggling with this all weekend.


Gimp-user mailing list

Reply via email to